StockFetcher Forums · Filter Exchange · Excluding sectors - can't get it to work<< >>Post Follow-up
cunparis
71 posts
msg #65310
Ignore cunparis
7/21/2008 10:38:13 AM

I try to exclude the energy sector but I can't get it to work (yes I've searched the forums).

I try;

set{sector_count, count(SECTOR is ENERGY, 1)}
sector_count is below 1

this returns all stocks. I added sector_count column and it's 0.00 for energy stocks. So the sector is energy part isn't working, it's never true.



SAFeTRADE
413 posts
msg #65311
Ignore SAFeTRADE
7/21/2008 11:02:17 AM

Try this

Fetcher[Price > 15
and sector not equal 5
and add column sector description
and add column sector
]



cunparis
71 posts
msg #65385
Ignore cunparis
7/24/2008 1:43:40 AM

Thank you very much. That will exclude energy, but I can't get it to exclude a specific industry. For example,

Price > 15
and sector equal 15
and industry not equal 170
and add column industry description
and add column industry

This shows stocks with industry = 170. Do you know how to filter out industries? I don't want anything to do with oil stocks! ;)




cunparis
71 posts
msg #65386
Ignore cunparis
7/24/2008 1:47:58 AM

Actually, it appears that your filter for sector doesn't work either. :(

I added average volume just to reduce the results. sort by sector in descending order, and you'll find energy stocks

average volume(10) is above 1000000
Price > 50
and sector not equal 15
and add column sector description
and add column sector



cunparis
71 posts
msg #65435
Ignore cunparis
7/25/2008 4:01:59 PM

I confirmed with SF support that it's not possible. The ignore list is an option, but since I'm using the appy to watchlist() the ignore list isn't used. So I'm out of luck on this one. I hope they'll add a feature for this.


SAFeTRADE
413 posts
msg #65438
Ignore SAFeTRADE
7/25/2008 10:06:00 PM

Another option is to screen for all energy stocks and check them all and click "IGNORE CHECKED" at the bottom of the page.

cunparis
71 posts
msg #65447
Ignore cunparis
7/26/2008 3:23:03 AM

The problem is if you use apply to then the ignore list isn't used. ignore list is only for when scanning the entire universe of stocks. Since I use watchlists this doesn't work for me. Of course I could and should go through my watchlists and remove all the oil stocks, but that's pretty time-consuming.



StockFetcher Forums · Filter Exchange · Excluding sectors - can't get it to work<< >>Post Follow-up

*** Disclaimer *** StockFetcher.com does not endorse or suggest any of the securities which are returned in any of the searches or filters. They are provided purely for informational and research purposes. StockFetcher.com does not recommend particular securities. StockFetcher.com, Vestyl Software, L.L.C. and involved content providers shall not be liable for any errors or delays in the content, or for any actions taken based on the content.


Copyright 2016 - Vestyl Software L.L.C.Terms of Service | License | Questions or comments? Contact Us
EOD Data sources: DDFPlus & CSI Data Quotes delayed during active market hours. Delay times are at least 15 mins for NASDAQ, 20 mins for NYSE and Amex. Delayed intraday data provided by DDFPlus